1999 Jeep XJ - Won't start! [SOLVED!] - Jeep Cherokee Forum xjTalk
Jeep Cherokee Forum xjTalk
ShopJeepParts.com
Advertise on xjtalk
  

Go Back   Jeep Cherokee Forum xjTalk > It's Technical... > OEM/Factory

Notices

OEM/Factory Adding or repairing items that came from, or would have come from the factory. (ex: replacing alternator, won't start, water pump, etc...)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-25-2012
Mudderoy's Avatar
Mudderoy Mudderoy is online now
"Just some guy"
Tony's Information
 
Join Date: Mar 2009
Location: Katy, Texas
Posts: 22,784
Thanks: 8,364
Thanked 5,319 Times in 3,308 Posts
Groans: 10
Groaned at 13 Times in 12 Posts
Chats: 24964
Mudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond repute
Garage
windows_98_nt_2000ie
View Mudderoy's Twitter Profile
Default 1999 Jeep XJ - Won't start! [SOLVED!]

I received a text message this afternoon from my recently started driving daughter. She said the Jeep wouldn't start and Mom was taking her to work.

I asked her several questions and here are the symptoms.

1. Won't start but seems to want to.
2. Started and ran fine this morning (going to school)
3. Started and ran fine this afternoon (coming home from school)
4. A few hours later when she was going to work, wouldn't start.

My wife not knowing that you aren't supposed to mess with the throttle when starting a fuel injected vehicle tried the old school method of pumping the gas while starting. She said it seemed to want to start more when she did that but still wouldn't start.

From work I spoke with her and told her how you are supposed to let the computer handle all that and maybe she flooded it when she was pumping the throttle before. I asked if she wanted to go try starting it. She agreed.

Now with her foot off the gas pedal she started the engine, and moved it up the driveway a bit.

She turned it off, tried starting it again, and it wouldn't start!

After I got home from work I tried starting it, started fine. I ran it for a few seconds and killed it. I tried starting it again. It wouldn't start.

Battery was strong, everything appeared to be fine, just wouldn't start. You could her it try every so often, but not enough that would even give you the slightest hope.

This was really strange.

I started checking connections, first visually then by taking them off and putting them back on the sensors.

CKS, CPS, TPS, IAC, MAT. I tried starting with the CKS off and it wouldn't even try, as expected. The reconnected it and disconnect the CPS, and again, wouldn't even try to start. So it seemed that signals were getting from these two position sensors to the ECM.

I checked a few other things, like fuel pressure, fine, the throttle body butterfly was opening and closing with the throttle.

So then I wondered if the ECM was moving the butterfly via the TPS during start. Hard to check when you are the one starting so I thought I could act as a TPS and press on the gas pedal a little during start, vrooom it started.

I let off the gas and it died. I tried again, it started...

Hmmm bad TPS? I've never had one fail like this before. I took the throttle body off, CLEANED IT THE HELL UP! Boy was it dirty inside. Then grabbed an after market TPS that I had on my 1998 until recently when I replaced it with a real Chrysler part.

Put the throttle body back on, hooked up all the sensors, and started it. Started fine and runs smooth.

I know I should disconnect the batter to clear the computer, but this is eating into my nap time.

My youngest daughter and I started and stopped about 10 times, worked each and every time.

Dunno, but my oldest daughter certainly got lucky that it worked fine until she got home and parked in the driveway! lol
__________________
Reply With Quote
The Following User Says Thank You to Mudderoy For This Useful Post:
Brasscatz (01-27-2012)
  #2  
Old 01-25-2012
Brasscatz's Avatar
Brasscatz Brasscatz is offline
Super Moderator
Jim's Information
 
Join Date: Jan 2012
Location: Houston
Posts: 12,377
Thanks: 8,478
Thanked 2,938 Times in 1,892 Posts
Groans: 1
Groaned at 3 Times in 3 Posts
Chats: 3130
Brasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond repute
Garage
windows_xp_2003firefox
Default Re: 1999 Jeep XJ - Won't start!

You know what? Sometimes, when I get into it in the morning, it will crank very sputter and not start. Then I feather the throttle just a tad and crank for a little while... it'll finally start up but I have to keep feathering the gas or it dies and I start at square one. I do this lightly while backing out of the garage, and starting out in drive (using neutral and gravity as much as possible). By the time I drive it with normal throttle for about a block or 2, all returns to normal.

Now, I've noticed that if I turn the key to ON and let the fuel pump do it's thing, then keep the key turned just a split second longer when it fires, this problem doesn't seem to occur. Why? I don't know. It seemed to happen consistently when I was having problems with reverse feeling like neutral and having to push the jeep out of the garage. Since I haven't had the start/sputter problem, I haven't had the reverse problem. Weird? I think so. This led me to think something with the TCM. But TPS could be the answer for me as well, and the reverse issue is completely separate!

Sorry to ramble on, but your starting issue seems very similar to mine, and it seems like you found the culprit in the TPS! I guess the question is, do you think that your issue may have come from the key being released before the motor was fully fired up? Sorry if that's a dumb question.
__________________


Reply With Quote
  #3  
Old 01-25-2012
Brasscatz's Avatar
Brasscatz Brasscatz is offline
Super Moderator
Jim's Information
 
Join Date: Jan 2012
Location: Houston
Posts: 12,377
Thanks: 8,478
Thanked 2,938 Times in 1,892 Posts
Groans: 1
Groaned at 3 Times in 3 Posts
Chats: 3130
Brasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond reputeBrasscatz has a reputation beyond repute
Garage
windows_xp_2003firefox
Default Re: 1999 Jeep XJ - Won't start!

Here's also an interesting link for service bulletins and recalls
http://www.alldatadiy.com/TSB/04/990417d2.html

These entries may be interesting:
18-36-98 DEC 98 PCM - Start and Stall, Idle Undershoot/Lost IAC Steps
8-46-98 DEC 98 Engine Idle Undershoot/Driveway Die Out
26-04-99D APR 99 Engine Controls/Fuel/Ignition Systems - Revisions
etc.
etc.

I don't know what you could do with that info without paying for more access, though. If I remember correctly, your public library should have a chilton online site through the library website, and that has recalls and TSBs too. All you need is your library card number I think.
__________________


Reply With Quote
  #4  
Old 01-27-2012
4.3LXJ's Avatar
4.3LXJ 4.3LXJ is online now
Super Moderator
Steve's Information
 
Join Date: Sep 2009
Location: Chico, CA
Posts: 20,513
Thanks: 3,849
Thanked 5,738 Times in 4,047 Posts
Groans: 0
Groaned at 5 Times in 5 Posts
Chats: 1625
4.3LXJ has a reputation beyond repute4.3LXJ has a reputation beyond repute4.3LXJ has a reputation beyond repute4.3LXJ has a reputation beyond repute4.3LXJ has a reputation beyond repute4.3LXJ has a reputation beyond repute4.3LXJ has a reputation beyond repute4.3LXJ has a reputation beyond repute4.3LXJ has a reputation beyond repute4.3LXJ has a reputation beyond repute4.3LXJ has a reputation beyond repute
macossafari
Default Re: 1999 Jeep XJ - Won't start!

Tony, you might want to check the fuel rail pressure just for giggles.
__________________
230 hp 4.3L Chevy
Built 4L60E with manual lockout
Atlas 4 speed
Griffin radiator
On board air
Warn 9.5ti on custom bumper
7.5" RE front and bastard pack rear on custom long arms
30 gal gas tank
lockers
And a bunch of other stuff
Reply With Quote
  #5  
Old 01-27-2012
xjsnake's Avatar
xjsnake xjsnake is offline
Level: Hummer (H2)
Jerrod's Information
 
Join Date: Jan 2012
Location: OH, TN, MI
Posts: 7
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
Chats: 1
xjsnake is on a distinguished road
windows_98_nt_2000firefox
Default Re: 1999 Jeep XJ - Won't start!

It's amazing what all the TPS can mess up when it's going bad
Reply With Quote
  #6  
Old 01-27-2012
Mudderoy's Avatar
Mudderoy Mudderoy is online now
"Just some guy"
Tony's Information
 
Join Date: Mar 2009
Location: Katy, Texas
Posts: 22,784
Thanks: 8,364
Thanked 5,319 Times in 3,308 Posts
Groans: 10
Groaned at 13 Times in 12 Posts
Chats: 24964
Mudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond repute
Garage
windows_98_nt_2000firefox
View Mudderoy's Twitter Profile
Default Re: 1999 Jeep XJ - Won't start!

Quote:
Originally Posted by Brasscatz View Post
You know what? Sometimes, when I get into it in the morning, it will crank very sputter and not start. Then I feather the throttle just a tad and crank for a little while... it'll finally start up but I have to keep feathering the gas or it dies and I start at square one. I do this lightly while backing out of the garage, and starting out in drive (using neutral and gravity as much as possible). By the time I drive it with normal throttle for about a block or 2, all returns to normal.

Now, I've noticed that if I turn the key to ON and let the fuel pump do it's thing, then keep the key turned just a split second longer when it fires, this problem doesn't seem to occur. Why? I don't know. It seemed to happen consistently when I was having problems with reverse feeling like neutral and having to push the jeep out of the garage. Since I haven't had the start/sputter problem, I haven't had the reverse problem. Weird? I think so. This led me to think something with the TCM. But TPS could be the answer for me as well, and the reverse issue is completely separate!

Sorry to ramble on, but your starting issue seems very similar to mine, and it seems like you found the culprit in the TPS! I guess the question is, do you think that your issue may have come from the key being released before the motor was fully fired up? Sorry if that's a dumb question.
No worries that was the point of my post to help someone else with a similar problem.

I literally cranked the engine for 30 seconds several times. I really thought it was the CPS when I first heard about the problem, so I was trying to get the computer lots of time to figure out where the chunk of metal was on the flywheel.

After replacing the TPS it was night and day difference. From no start to start each and every time.
__________________
Reply With Quote
The Following User Says Thank You to Mudderoy For This Useful Post:
Brasscatz (01-27-2012)
  #7  
Old 01-27-2012
Mudderoy's Avatar
Mudderoy Mudderoy is online now
"Just some guy"
Tony's Information
 
Join Date: Mar 2009
Location: Katy, Texas
Posts: 22,784
Thanks: 8,364
Thanked 5,319 Times in 3,308 Posts
Groans: 10
Groaned at 13 Times in 12 Posts
Chats: 24964
Mudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond reputeMudderoy has a reputation beyond repute
Garage
windows_98_nt_2000firefox
View Mudderoy's Twitter Profile
Default Re: 1999 Jeep XJ - Won't start!

Quote:
Originally Posted by 4.3LXJ View Post
Tony, you might want to check the fuel rail pressure just for giggles.
Sorry I meant to include that in the original post. It was the first thing I checked. 50 psi (once I got it running) about 40 psi after turning the key on and off 3 times.

The assembly in the gas tank needs to be replaced as the fuel pressure drops off pretty quickly, but it isn't nearly as bad as what it was on my 1998.
__________________
Reply With Quote
Reply

Bookmarks

Tags
1999, jeep, start
Home Forums Articles Register FAQ Members List Calendar Search Today's Posts Mark Forums Read


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 Jeep XJ - TimKen Wheel Bearing and Hub Mudderoy OEM/Factory 1 10-27-2011 01:34 AM
New tires and wheels for the 1999 Jeep XJ. Mudderoy Modified 19 07-02-2011 09:43 PM
The 1999 Jeep XJ Needs little paint touch ups. Mudderoy Body Repair 2 06-23-2011 04:32 PM
1991 - 1999 Jeep Cherokee Exhaust Manifold with Gasket Kit Stainless Steel 4.0L 242ci 1ATony Vendors - For Sale 3 03-18-2011 06:56 PM
1999 - 2001 Jeep Cherokee Timing Chain Set for Models with L6 4.0L (8th Vin Digit S) 1ATony Vendors - For Sale 0 09-16-2010 12:45 PM


Advertise with us through Google's Adsense Direct!

VigLink badge

Large Visitor Map

All times are GMT -5. The time now is 12:33 PM.

Powered by vBulletin® Copyright ©2000 - 2008, Jelsoft Enterprises Ltd.
Garage vBulletin Plugins by Drive Thru Online, Inc.

Style Provided By: Wrestling Clique - Wrestling Forums
Jeep, Cherokee, are copyrighted and trademarked to the Jeep/Chrysler Corporation
xjtalk is not in any way associated with Jeep or the Chrysler Corp.

no new posts