Page 1 of 2 12 LastLast
Results 1 to 15 of 19
  1. #1
    Join Date
    May 2019
    Location
    New Lenox ILLINOIS
    Posts
    1
    Chats
    0

    Default New member needs mechanics help

    1998 XJ 4.0 automatic. Keeps throwing codes at me p0204,p0205 can play with injectors the codes will stop and it will run good but after 5-10 miles codes come back. Not always the same have gotten p0201 and p0203 as well normally not more than 2 codes at a time. So far I replaced all fuel injectors, new tps, had new plugs and wires on it. Also tried replacing the computer from another XJ same year and all but still got the codes. I donít mind buying parts but this XJ needs a lot so I only want to buy parts I need until its running good. After that I plan to continue to buy and replace parts for reliability. Goal is to have it reliable for my son to drive daily, however I know he likes mud. Any help is greatly appreciate
    Last edited by Jboden615; 05-19-2019 at 10:02 PM.

  2. #2
    Join Date
    Aug 2014
    Location
    Hunt County Texas
    Posts
    313
    Chats
    3

    Default Re: New member needs mechanics help

    Check and double check all your grounds, even if they look good take them off clean them then reinstall. Really you could probably benifit from a full battery cable and ground replacement.

    Then you need to start troubleshooting the injector harness. Get a multimeter if you dont have one set it to continuity mode and start shooting wires between the injector connections to the PCM, you may need to wiggle parts of the harness while doing this to see if you can replicate a wire break.

    Those codes are specifically related to the injector circuit so nothing on the ignition side should be an issue.

    Sent from my SM-G892A using Tapatalk
    Last edited by downsy; 05-20-2019 at 10:15 AM.
    1995 XJ / 4.0L / AW4 / D30 w/No-Slip Locker / C8.25 / UPCOUNTRY spec suspension / 235/75R15

  3. #3
    Join Date
    Sep 2009
    Location
    Chico, CA
    Posts
    29,651
    Chats
    1838

    Default Re: New member needs mechanics help

    I agree. Since you have replaced the injectors, it is in that circuit. One other thing, there is a product called OxGuard that really improves the conductivity of all the plug connections. Use it sparingly, apply with a tooth pic since it will bridge the spades if slopped on. It contains grit in it, so plug and unplug several times and will renew the surfaces of the plug
    230 hp 4.3L Chevy
    Built 4L60E with manual lockout
    Atlas 4 speed
    Griffin radiator
    On board air
    Warn 9.5ti on custom bumper
    7.5" RE front and bastard pack rear on custom long arms
    30 gal gas tank
    lockers
    And a bunch of other stuff

  4. #4
    Join Date
    May 2019
    Location
    New Lenox ILLINOIS
    Posts
    1
    Chats
    0

    Default Re: New member needs mechanics help

    Ok did a little testing with volt meter from neutral on battery to each green / orange injector wire with engine running and get 13.9 on all wires. Also used a basic test light with engine running and test light is on and bright to each g/o wire. When I use test light on the other wire I get a dim light that flickers or blinks. I would assume that is firing. Not sure how to do test on the pcm or where and what that is.

  5. #5
    Join Date
    May 2019
    Location
    New Lenox ILLINOIS
    Posts
    1
    Chats
    0

    Default Re: New member needs mechanics help

    How would that change with engine off. Can I check continuity with wires and battery?

  6. #6
    Join Date
    Sep 2009
    Location
    Chico, CA
    Posts
    29,651
    Chats
    1838

    Default Re: New member needs mechanics help

    Do you actually feel a miss when this happens?
    230 hp 4.3L Chevy
    Built 4L60E with manual lockout
    Atlas 4 speed
    Griffin radiator
    On board air
    Warn 9.5ti on custom bumper
    7.5" RE front and bastard pack rear on custom long arms
    30 gal gas tank
    lockers
    And a bunch of other stuff

  7. #7
    Join Date
    May 2019
    Location
    New Lenox ILLINOIS
    Posts
    1
    Chats
    0

    Default Re: New member needs mechanics help

    Not 100% sure if I could hear it but can feel a difference while driving then check engine light goes on. Got new connectors for the fuel injectors today ( thanks amazon) so I will butt splice them in tonight I hope. Donít know if that will help or not.

  8. #8
    Join Date
    Sep 2009
    Location
    Chico, CA
    Posts
    29,651
    Chats
    1838

    Default Re: New member needs mechanics help

    We had a similar problem with a TJ 4.0. It didn't really affect the drivability, but did throw a CEL. Put a tank of premium gas in it and got rid of the problem as long as we ran it. Passed inspection and then went back to regular and a light
    230 hp 4.3L Chevy
    Built 4L60E with manual lockout
    Atlas 4 speed
    Griffin radiator
    On board air
    Warn 9.5ti on custom bumper
    7.5" RE front and bastard pack rear on custom long arms
    30 gal gas tank
    lockers
    And a bunch of other stuff

  9. #9
    Join Date
    May 2019
    Location
    New Lenox ILLINOIS
    Posts
    1
    Chats
    0

    Default Re: New member needs mechanics help

    It has fresh gas as I just bought it and came empty. When I drive it I can feel a problem like a misfire lack of power and rough.

  10. #10
    Join Date
    Sep 2009
    Location
    Chico, CA
    Posts
    29,651
    Chats
    1838

    Default Re: New member needs mechanics help

    Any problems with coolant loss?
    230 hp 4.3L Chevy
    Built 4L60E with manual lockout
    Atlas 4 speed
    Griffin radiator
    On board air
    Warn 9.5ti on custom bumper
    7.5" RE front and bastard pack rear on custom long arms
    30 gal gas tank
    lockers
    And a bunch of other stuff

  11. #11
    Join Date
    May 2019
    Location
    New Lenox ILLINOIS
    Posts
    1
    Chats
    0

    Default Re: New member needs mechanics help

    Not leaking but really have not but any miles on since I bought it. To busy replacing parts to drive it. I have had it less than a month and have installed fuel injectors, full rear brakes with hardware cables and lines, front brakes with new calipers, brake master cylinder, both transmission cooling lines, radiator hoses, tps sensor, new radio and speakers. Tonight cleaning all the different grounds and it looks like the two close to block passengers side will need replacing tomorrow. My plan is to butt splice new #8 wire to some spot on existing wire and add new ring connectors. Think I over payed for this XJ now because it was not rusted but itís needing more mechanical work than I thought.

  12. #12
    Join Date
    May 2019
    Location
    New Lenox ILLINOIS
    Posts
    1
    Chats
    0

    Default Re: New member needs mechanics help

    Also see about 1/2-3/4 of a each of bare copper wires coming out of the ignition coil harness connector. Not sure how to replace the connector or just get some good electrical tape between the wires and then tape them up.

  13. #13
    Join Date
    Sep 2009
    Location
    Chico, CA
    Posts
    29,651
    Chats
    1838

    Default Re: New member needs mechanics help

    Next question which I probably know the answer to. How long has the O2 sensor been in there? No one ever changes them until it is too late
    230 hp 4.3L Chevy
    Built 4L60E with manual lockout
    Atlas 4 speed
    Griffin radiator
    On board air
    Warn 9.5ti on custom bumper
    7.5" RE front and bastard pack rear on custom long arms
    30 gal gas tank
    lockers
    And a bunch of other stuff

  14. #14
    Join Date
    May 2019
    Location
    New Lenox ILLINOIS
    Posts
    1
    Chats
    0

    Default Re: New member needs mechanics help

    I have not changed either o2 sensor yet but did repair wiring to the one on drivers side towards front of engine. Should I be replacing them both? How would that help me.

  15. #15
    Join Date
    May 2019
    Location
    New Lenox ILLINOIS
    Posts
    1
    Chats
    0

    Default Re: New member needs mechanics help

    With o2 sensor does brand matter local auto zone has Bosch at 52-62 each but I see other brands on line less than half the price?

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 2
    Last Post: 05-29-2016, 05:28 PM
  2. Replies: 6
    Last Post: 07-30-2014, 06:26 AM
  3. Best Mechanics Tool Set
    By Kimber6331 in forum General Talk
    Replies: 11
    Last Post: 05-24-2012, 12:21 AM
  4. jimwww - just got back from the mechanics
    By jimwww in forum Rig Pictures
    Replies: 10
    Last Post: 09-11-2009, 05:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •