Results 1 to 8 of 8
  1. #1
    Join Date
    Oct 2009
    Location
    Baltimore
    Posts
    51
    Chats
    0

    Question Low idle started after check engine light went off

    My issue: After starting and warming up my 2001 Limited, during a stop at a red light, the idle will drop and "bounce" between 200 and 500 rpm and at times completely die. As mentioned this only occurs at a red light or stop either with the engine in D or N. It just started about 2+ weeks ago and is getting progressively worse but only after engine warm up. Other than that it drives great with no other issues.
    Not sure if this has anything to do with the problem but about a month and a half ago my check light came on. After taking it to AutoZone and having them check it with a OBDII scanner, I was told the code was my CAT converter and should be replaced. A week or so later the check engine light went off. Fast forward another week the light came on again but only for a few days. I never got it checked this the second time thinking it was the CAT again. A few days later it went off and has been off since which now is going on a few weeks. Not long after the idle issue surfaced. I took the XJ to my mechanic about the idle issue and told him about the check engine light previously being on and what AutoZone told me. He tried to "pull" the previous code from the ECM using his OBDII scanner and he couldn't find any codes present.
    Is there another way to "find" the previous codes and would a bad CAT have anything to do with the idle issue?
    What steps should I take to systematically eliminate items that could be causing the low idle? Should I replace the CAT after what AutoZone told me even though my mechanic couldn't recover any codes? Sorry such a long read but any and all help would be greatly appreciated. Thanks all.

  2. #2
    Join Date
    Sep 2009
    Location
    Chico, CA
    Posts
    29,703
    Chats
    1838

    Default Re: Low idle started after check engine light went off

    How long has it been since the O2 sensors have been changed?
    230 hp 4.3L Chevy
    Built 4L60E with manual lockout
    Atlas 4 speed
    Griffin radiator
    On board air
    Warn 9.5ti on custom bumper
    7.5" RE front and bastard pack rear on custom long arms
    30 gal gas tank
    lockers
    And a bunch of other stuff

  3. #3
    Join Date
    Oct 2009
    Location
    Baltimore
    Posts
    51
    Chats
    0

    Default Re: Low idle started after check engine light went off

    Quote Originally Posted by 4.3LXJ View Post
    How long has it been since the O2 sensors have been changed?
    Not in the 10 years I've had it..

    But wouldn't I get a check engine code if the O2 sensor was faulting?
    Last edited by Mr Clean; 03-18-2017 at 10:38 PM.

  4. #4
    Join Date
    Sep 2009
    Location
    Chico, CA
    Posts
    29,703
    Chats
    1838

    Default Re: Low idle started after check engine light went off

    Not necessarily. The only way you get one is if the wires are disconnected or the heater in them fails. The signal generating part just wears out over time. You might need a cat, but to be sure about that without sniffing the tailpipe you should replace the sensors. You might even get better milage out of it. Worn out sensors will affect the fuel/air ratio and most likely the idle as well as high end performance.
    230 hp 4.3L Chevy
    Built 4L60E with manual lockout
    Atlas 4 speed
    Griffin radiator
    On board air
    Warn 9.5ti on custom bumper
    7.5" RE front and bastard pack rear on custom long arms
    30 gal gas tank
    lockers
    And a bunch of other stuff

  5. #5
    Join Date
    Oct 2009
    Location
    Baltimore
    Posts
    51
    Chats
    0

    Default Re: Low idle started after check engine light went off

    Just an update in case someone else has had this type of issue. I cleaned my throttle body and IAC valve and it (the low idle issue) has stopped! The only occasional issue I'm having now is the heat sink on #3 which will be taken care of soon.

  6. #6
    Pinkyman's Avatar
    Pinkyman is offline Level: Uber Jeep Cherokee Trailer Queen
    Join Date
    Sep 2015
    Location
    Monticello, MN
    Posts
    1,376
    Chats
    71

    Default Re: Low idle started after check engine light went off

    Quote Originally Posted by Mr Clean View Post
    Just an update in case someone else has had this type of issue. I cleaned my throttle body and IAC valve and it (the low idle issue) has stopped! The only occasional issue I'm having now is the heat sink on #3 which will be taken care of soon.
    I was going to ask about your IAC valve... I had the same issue with mine, i cleaned it, and after resetting the computer it was good as new

  7. #7
    Join Date
    Oct 2009
    Location
    Baltimore
    Posts
    51
    Chats
    0

    Default Re: Low idle started after check engine light went off

    Quote Originally Posted by Pinkyman View Post
    I was going to ask about your IAC valve... I had the same issue with mine, i cleaned it, and after resetting the computer it was good as new
    Same here, runs 110% better

  8. #8
    Join Date
    Aug 2009
    Location
    Asheville, NC
    Posts
    7,960
    Chats
    39048

    Default Re: Low idle started after check engine light went off

    Glad you got it worked out, and didn't have to throw a bunch of parts at it to get it going good...
    FORMER GREEN XJ CLUB MEMBER
    IF YOU DON'T STAND BEHIND OUR TROOPS, FEEL FREE TO STAND IN FRONT OF THEM!!
    DOING SOMETHING JUST BECAUSE YOUR BUDDY DOES IT THAT WAY MAKES AS MUCH SENSE AS SHARING TOOTHBRUSHES

Similar Threads

  1. Check engine light- EVAP
    By ArmyGuy45 in forum General Talk
    Replies: 18
    Last Post: 06-15-2013, 01:05 PM
  2. Check engine light
    By Hercules in forum General Talk
    Replies: 3
    Last Post: 05-24-2013, 12:00 PM
  3. Check Engine Light woes...
    By One_Big_Midgett in forum OEM/Factory
    Replies: 22
    Last Post: 06-16-2012, 01:13 PM
  4. Check engine light
    By Punisher in forum OEM/Factory
    Replies: 22
    Last Post: 01-25-2012, 10:36 PM
  5. Dirty=check ingine light/clean=no check engine light?
    By Switch_knuckles in forum General Talk
    Replies: 4
    Last Post: 03-03-2011, 12:47 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •