Page 2 of 2 FirstFirst 12
Results 16 to 22 of 22
  1. #16
    Join Date
    Jun 2014
    Location
    ozarks
    Posts
    29
    Chats
    0

    Default Re: HELP find my missing coolant!!

    Engine temp gauge appears to read normal temps, I wanna say around 210 or so. I don't notice any smoke or anything that looks like evaporated coolant coming out either.

    I do notice the oil pressure fluctuations with the microguard oil filter. Low pressure at startup, increases as rpm's increase.

  2. #17
    Join Date
    Dec 2013
    Location
    Minnesota
    Posts
    1,618
    Chats
    4028

    Default Re: HELP find my missing coolant!!

    My guess is that it's either puking out as you're driving or there's a small leak at operating temp like was stated before.

  3. #18
    Join Date
    Jun 2014
    Location
    ozarks
    Posts
    29
    Chats
    0

    Default Re: HELP find my missing coolant!!

    That's making more & more sense. Seems like longer drive drives, i.e. Longer duration at operating temp, more coolant lost. How do you track that leak down?

  4. #19
    Join Date
    Dec 2013
    Location
    Minnesota
    Posts
    1,618
    Chats
    4028

    Default Re: HELP find my missing coolant!!

    Look for smoke or white crusty gunk on stuff in the engine compartment is a start. Radiator, hose connections, water pump, heater hoses.

  5. #20
    Join Date
    Jun 2014
    Location
    ozarks
    Posts
    29
    Chats
    0

    Default Re: HELP find my missing coolant!!

    Thanks! I'll pop the hood & take a look later today.

  6. #21
    abebehrmann's Avatar
    abebehrmann is offline Level: Uber Jeep Cherokee Trailer Queen
    Join Date
    May 2013
    Location
    Dallas, TX
    Posts
    6,597
    Chats
    2359

    Default Re: HELP find my missing coolant!!

    I had the same problem for about a year. Never could figure out what it was until I drove it for a long time on a hot day and then searched around with it running. Turned out my lower radiator hose clamp was just a teeny tiny bit loose and it was very slowly seeping out.

  7. #22
    Join Date
    Oct 2011
    Location
    S.E. Texas
    Posts
    29,251
    Chats
    1247

    Default Re: HELP find my missing coolant!!

    Definitely check the hose ends like Abe said. They can crack and get corroded and coolant can seep out. Had its happen a couple times myself.

    Also sometimes when the water pump is going out it will leak from its "weep hole". While it's running get up under the front end and check the bottom of the water pump, being careful of moving parts of course.

    And it's not probable since it's running fine but you can do a compression test to check for a head crack/leaking gasket. You can rent the tester from the usual auto parts stores and it's easy to check.

    Sent via messenger pigeon. I talk, he types.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. What is missing?
    By NC_Xplorer in forum General Talk
    Replies: 12
    Last Post: 08-23-2015, 08:49 AM
  2. Am I missing ??? - Where do these go?
    By Crist Clapper in forum General Talk
    Replies: 7
    Last Post: 05-04-2014, 06:51 PM
  3. What's missing in these photos?
    By Crist Clapper in forum General Talk
    Replies: 48
    Last Post: 04-08-2014, 08:45 PM
  4. Missing and running like #### tj
    By cantab27 in forum Wrangler - General
    Replies: 7
    Last Post: 05-15-2013, 07:42 AM
  5. Missing Fuses?
    By Nexusone9mm in forum Electrical and Audio Tips! from JEEP TALK SHOW! Podcast
    Replies: 3
    Last Post: 03-08-2013, 08:48 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •