Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2011
    Location
    s.california
    Posts
    179
    Chats
    2

    Default Brakes help please!!

    hello all, im having trouble with my brakes.. im not sure front or rear. feels like all of them at different times. ok so i start my jeep and drive about 20yards or so before i come to an intersection. i very, very lightly apply brakes and either all of some of my wheels lock up. im only driving about 5-10 mph.
    as soon as i let off they rotate normally. come to a stop again and they do it again.. i even get tire screech. scares everyone in the jeep... i continue driving and after about 10mins of driving it doesnt do it anymore at all.. until i park and leave it over night.. it ONLY happens in really, really cold morning weather or rain forsure. i thought maybe the ABS system was acting up or dirty sensors or something so to try a quick test i removed ALL relays and fuses disabling the ABS system. wait the next day as it is still raining start the xj, lightly apply brakes and they still do it.... any and all help is appreciated!

  2. #2
    Join Date
    Sep 2009
    Location
    Chico, CA
    Posts
    29,703
    Chats
    1838

    Default Re: Brakes help please!!

    Sounds complicated doesn't it? It is a simple fix though. Your pads and shoes are made of material that is too soft and combined with a slight amount of moisture, they grab. Once they get warm, then they don't. I would suggest getting some good shoes and pads, preferably ceramic. It is the best braking material yet. It absolutely doesn't fade with heat, so the characteristics don't change with temperature
    230 hp 4.3L Chevy
    Built 4L60E with manual lockout
    Atlas 4 speed
    Griffin radiator
    On board air
    Warn 9.5ti on custom bumper
    7.5" RE front and bastard pack rear on custom long arms
    30 gal gas tank
    lockers
    And a bunch of other stuff

  3. #3
    Join Date
    Aug 2011
    Location
    s.california
    Posts
    179
    Chats
    2

    Default Re: Brakes help please!!

    That makes alot of sense... read someone elses situation and changing pads and shoes fully cured there problem. Also my back brakes where you adjust the shoe is missing the rubber plugs that seal it when done adjusting. I would assume alot of water and moisture enter there..

Similar Threads

  1. Well crap- Brakes
    By ArmyGuy45 in forum General Talk
    Replies: 8
    Last Post: 12-27-2015, 11:22 AM
  2. Power brakes
    By tommy guns in forum General Talk
    Replies: 1
    Last Post: 07-29-2013, 03:24 AM
  3. brakes...help
    By 4x4troy in forum OEM/Factory
    Replies: 2
    Last Post: 11-01-2012, 11:58 AM
  4. No Brakes!
    By Outlaw in forum OEM/Factory
    Replies: 12
    Last Post: 07-11-2011, 08:41 AM
  5. no brakes ...
    By cantab27 in forum OEM/Factory
    Replies: 23
    Last Post: 11-11-2010, 02:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •