Results 1 to 9 of 9
  1. #1
    Join Date
    Jul 2014
    Location
    Washington
    Posts
    4
    Chats
    0

    Default 1993 XJ Bad Noise

    I bought this 1993 XJ Country a few months ago, a tow car that has 153,000 miles but it has been sitting in a garage for some time, maybe years, and I have had trouble getting it to go into 4wd. Select Trac transmission. After trying a few times it went in to fulltime 4wd mode. Now, after putting it back into 2wd mode, when I turn on the key it makes a awful schreeching noise from the transmission. The engine doesn't need to be running, I just turn the key is on and the noise starts. Like an electric motor is running and there is a bad bearing or a warn bushing. The noise is very loud and it is coming from the transmission. Any ideas? Is it terminal or can I keep driving? If it is electrical, can I disconnect a wire or pull a fuse to stop it for now? Is there a fix I can do myself or is this a transmission shop job?

    Scott

  2. #2
    Join Date
    Sep 2009
    Location
    Chico, CA
    Posts
    29,703
    Chats
    1838

    Default Re: 1993 xj Bad Noise

    Do you have a check engine light on when the engine is running?
    230 hp 4.3L Chevy
    Built 4L60E with manual lockout
    Atlas 4 speed
    Griffin radiator
    On board air
    Warn 9.5ti on custom bumper
    7.5" RE front and bastard pack rear on custom long arms
    30 gal gas tank
    lockers
    And a bunch of other stuff

  3. #3
    Join Date
    Dec 2011
    Location
    Three Oaks
    Posts
    458
    Chats
    0

    Default Re: 1993 xj Bad Noise

    Can you shift the transfer case into neutral ?
    Did you do the shifting of the transfer case with the engine running ?
    Any more you can tell us ?
    The AW4 auto is electronically controlled. 1st off check if you have sufficient trans fluid in the case. You should be able to read any TCU (Trans Control Unit) codes out via OBDII reader. I believe this is why 4.3LXJ asked if you have a CEL set.

  4. #4
    Join Date
    Jul 2014
    Location
    Washington
    Posts
    4
    Chats
    0

    Default Re: 1993 xj Bad Noise

    The check engine light isn't on, the trans fluid is full and clean. I shifted the transfer case while moving slowly. The noise lasts for about a minute after the key is turned on then seems to stop. It must be something electrical because the noise is there if the engine is running or not.

  5. #5
    Join Date
    Sep 2009
    Location
    Chico, CA
    Posts
    29,703
    Chats
    1838

    Default Re: 1993 XJ Bad Noise

    What I suspect is one of the solenoids in the trans. That is why I asked if there was a CEL. If you drop the pan, they are easy to replace. Does it shift normally?
    230 hp 4.3L Chevy
    Built 4L60E with manual lockout
    Atlas 4 speed
    Griffin radiator
    On board air
    Warn 9.5ti on custom bumper
    7.5" RE front and bastard pack rear on custom long arms
    30 gal gas tank
    lockers
    And a bunch of other stuff

  6. #6
    Join Date
    Jul 2014
    Location
    Washington
    Posts
    4
    Chats
    0

    Default Re: 1993 XJ Bad Noise

    Yes, shifts ok and drives ok. I have it in 2wd now. The noise started after I drove for a while in full time 4wd and parked it overnight. The next time I turned the key it made the noise. Doesn't change no matter what the transfer case is shifted into. I can take a video and record the noise if you are interested.

    The reason I drove in 4wd is because the car had been sitting for a while before I bought it and someone told me that it should be driven in 4wd once in a while to keep everything lubricated, is that true?

  7. #7
    Join Date
    Sep 2009
    Location
    Chico, CA
    Posts
    29,703
    Chats
    1838

    Default Re: 1993 XJ Bad Noise

    I think we have established that it is not transfer case related. I had a relay make that same noise the other day when I didn't hook up a good ground to it. So, one recommendation I have here is to redo your grounds. They can go bad on an XJ over time
    230 hp 4.3L Chevy
    Built 4L60E with manual lockout
    Atlas 4 speed
    Griffin radiator
    On board air
    Warn 9.5ti on custom bumper
    7.5" RE front and bastard pack rear on custom long arms
    30 gal gas tank
    lockers
    And a bunch of other stuff

  8. #8
    Join Date
    Jul 2014
    Location
    Washington
    Posts
    4
    Chats
    0

    Default Re: 1993 XJ Bad Noise

    Thanks, I'll check it out. Do you run your XJ in 4wd once in a while or was that advise to me not true?

  9. #9
    Join Date
    Sep 2009
    Location
    Chico, CA
    Posts
    29,703
    Chats
    1838

    Default Re: 1993 XJ Bad Noise

    Well, yes I do. But only off road. I don't have the full time transfer case you do though.
    230 hp 4.3L Chevy
    Built 4L60E with manual lockout
    Atlas 4 speed
    Griffin radiator
    On board air
    Warn 9.5ti on custom bumper
    7.5" RE front and bastard pack rear on custom long arms
    30 gal gas tank
    lockers
    And a bunch of other stuff

Similar Threads

  1. Uuganaa's XJ 1993
    By Uuganbayar in forum My Build
    Replies: 39
    Last Post: 05-13-2019, 11:36 AM
  2. Problem with my 1993 XJ 4.0
    By YMP_5000 in forum General Talk
    Replies: 12
    Last Post: 02-04-2014, 10:40 AM
  3. Noise! Lots of Noise! Can't figure it out!
    By brianwy77 in forum OEM/Factory
    Replies: 6
    Last Post: 02-15-2011, 07:39 PM
  4. 1993 XJ Country Edition
    By Melissa in forum For Sale
    Replies: 0
    Last Post: 05-25-2010, 12:20 AM
  5. 1993 2dr sport
    By finneys98xj in forum For Sale
    Replies: 11
    Last Post: 04-27-2010, 10:10 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •