Results 1 to 6 of 6
  1. #1
    Join Date
    Aug 2011
    Location
    s.california
    Posts
    179
    Chats
    2

    Default **Power loss uphill**

    Hello all,
    my jeep is 95 xj with 70k 6cyl h.o
    it generally runs great on flat surface just kinda sluggish on passing cars and also going uphill it seems to struggle.. My main concern is going uphill though...air filter,fuel filter are almost new. Tune up was done about 6months ago. Can someone please give me a direction in where to start looking into??? Thanks!

  2. #2
    Join Date
    Sep 2009
    Location
    Chico, CA
    Posts
    29,677
    Chats
    1838

    Default Re: **power loss uphill**

    O2 sensor changed in that tune up?
    230 hp 4.3L Chevy
    Built 4L60E with manual lockout
    Atlas 4 speed
    Griffin radiator
    On board air
    Warn 9.5ti on custom bumper
    7.5" RE front and bastard pack rear on custom long arms
    30 gal gas tank
    lockers
    And a bunch of other stuff

  3. #3
    Join Date
    Aug 2011
    Location
    s.california
    Posts
    179
    Chats
    2

    Default Re: **power loss uphill**

    no..i bought the jeep with 65k and now has around 70k and i never replaced the o2 sensor cause it seems to run and idle fine...not sure if previous owner ever did..

  4. #4
    Join Date
    Sep 2009
    Location
    Chico, CA
    Posts
    29,677
    Chats
    1838

    Default Re: **power loss uphill**

    They are the most neglected tune up part there is. My opinion is that they be replaced every 50K, which is generous considering Jeeps says 28K. A lean or rich mixture due to faulty readings on it will rob the engine of power
    230 hp 4.3L Chevy
    Built 4L60E with manual lockout
    Atlas 4 speed
    Griffin radiator
    On board air
    Warn 9.5ti on custom bumper
    7.5" RE front and bastard pack rear on custom long arms
    30 gal gas tank
    lockers
    And a bunch of other stuff

  5. #5
    Join Date
    Aug 2011
    Location
    s.california
    Posts
    179
    Chats
    2

    Default Re: **power loss uphill**

    hmm. makes sense to me.. i will replace it this weekend and update..
    thanks 4.3LXJ!

  6. #6
    Join Date
    Aug 2011
    Location
    s.california
    Posts
    179
    Chats
    2

    Default Re: **Power loss uphill**

    UPDATE: replaced o2 sensor and power is way better now... driving uphill is a breeze and no more sluggishness.. didnt think o2 was faulty but after replacing it engine runs alot stronger.. thanks for the help!!

Similar Threads

  1. Loss of power (perhaps a miss) in my 4.0L
    By Mudderoy in forum Modified
    Replies: 3
    Last Post: 10-14-2013, 01:34 PM
  2. Replies: 5
    Last Post: 08-26-2012, 12:42 PM
  3. Replies: 4
    Last Post: 07-28-2012, 11:04 AM
  4. Portable Power? Emergency Power?
    By Mudderoy in forum General Talk
    Replies: 22
    Last Post: 09-07-2011, 12:23 AM
  5. TURN SIGNAL Loss
    By 88AMCOMANCHE in forum OEM/Factory
    Replies: 30
    Last Post: 05-13-2011, 08:08 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •