Results 1 to 13 of 13
  1. #1
    Join Date
    May 2013
    Location
    Georgia
    Posts
    1
    Chats
    0

    Default Problem with my 1993 XJ 4.0

    My wife called me at work and said the Jeep cut off on her and she was stranded. She said it would turn over but would not run. I pause and thanked God for blessing us with a vehicle so dependable to have rendered 261,000 miles of service. I then called a wrecker to pick both of them up but she called me back within 15 minutes and said that she gave it one more try and it started up and she was driving home. God is great but now I have no idea what is wrong with it. I have a few ideas on where to start (fuel filter and ignition coil) but I was wondering if anyone has had a similar issue and what the problem wound up being. Any help would be greatly appreciated as I don't want to rely on prayer to get us home from our next camping trip.
    Last edited by YMP_5000; 08-01-2013 at 10:21 AM.

  2. #2
    Join Date
    Jul 2012
    Location
    Mesa, AZ
    Posts
    800
    Chats
    696

    Default Re: Problem with my 1993 XJ 4.0

    Crank Shaft Position Sensor.
    US Army 2005 - 2014
    US Army Reserves 2014 - Present

    2001 XJ Limited 4dr I6 Auto.

    "Stand your ground. Don't fire unless fired upon, but if they mean to have a war, let it begin here!"

    Capt. John Parker, Lexington militia

  3. #3
    Join Date
    Oct 2011
    Location
    S.E. Texas
    Posts
    29,250
    Chats
    1247

    Default Re: Problem with my 1993 XJ 4.0

    Yes, the CPS (crank position sensor) is a very common issue with these motors. It can leave you stranded for a while then magically start right up. It just likes messing with people. There's no guaranty that's your problem but odds are in its favor.

    When replacing the CPS go with a quality replacement. Many suggest just going with the dealership part even though the price is high. You don't want to be doing this again shortly down the road, especially if your wife is going to be driving it.

    Here's a write up on replacement. Its fairly easy, just gotta squeeze up in there. http://jeep-xj.info/HowtoCPSchange.htm

    I personally suggest going at it from underneath drivers side between the front axle and transmission crossmember and disconnect the front driveshaft at the axle (be sure the caps don't fall off the u-joint) to help get up there. Have a few extensions and a u-joint for your ratchet handy.

    Sent via messenger pigeon - i talk, he types.
    Last edited by XJ Wheeler; 08-02-2013 at 01:37 AM.

  4. #4
    Join Date
    Jun 2013
    Location
    Florida
    Posts
    237
    Chats
    14

    Default Re: Problem with my 1993 XJ 4.0

    I had crankshaft position sensor replaced and coil was replaced. Tonight po351 is showing again. Mt engine stalls regularly and sometimes wont immediately start like u said above. It's driving me crazy.

  5. #5
    Join Date
    Jun 2010
    Location
    Calgary, AB
    Posts
    1,123
    Chats
    1626

    Default Re: Problem with my 1993 XJ 4.0

    If the jeep is stalling under deceleration, for example driving and lift off the throttle and it goes to stall check or bypass the EGR valve,.. Can cause similar symptoms.
    Stock:
    2007 SRT8 Grand Cherokee w/2008 upgrades
    2004 TJ Rubicon
    2000 Cherokee Sport 2 Dr - Donor
    2000 Grand Cherokee Laredo
    1990 Comanche Eliminator
    1990 Comanche Sport Truck
    1989 Comanche Sport Truck
    1988 Comanche
    1986 Comanche Metric Ton Turbo Diesel
    1989 Cherokee Chopped Comp Rig

    and thats just the jeeps

    WWW.RACINGFORTHECURE.CA

  6. #6
    Join Date
    Jun 2013
    Location
    Florida
    Posts
    237
    Chats
    14

    Default Re: Problem with my 1993 XJ 4.0

    I seems more like a dying or herky jerky. Sometimes putting in neutral an slightly reving seemed to prevent the stall. Also seems like a coil dying stall. Which is why I replaced coil and at the time I don't think I had a coil code. It's like chasing a ghost.

  7. #7
    Join Date
    Jun 2013
    Location
    Florida
    Posts
    237
    Chats
    14

    Default Re: Problem with my 1993 XJ 4.0

    Auto Zone doesn't even show an egr for 98 jgc

  8. #8
    Join Date
    Apr 2009
    Location
    Salem Va.
    Posts
    890
    Chats
    0

    Default Re: Problem with my 1993 XJ 4.0

    4.0 don't have EGR valve

    Sent from my XT907 using Tapatalk
    Last edited by drakan1908; 01-30-2014 at 07:00 AM.

  9. #9
    Join Date
    Jun 2013
    Location
    Florida
    Posts
    237
    Chats
    14

    Default Re: Problem with my 1993 XJ 4.0

    Ok today driving to work it stalled or tried and didn't do much tonight but tried once or twice. I replaced horn and fuel pump relay so its not the relay because it still back fired and tried stalling, If it were the pcm I cant see throwing it in neutral and revving it slightly which seems to prevent the stall....as a pcm issue. As of now I'm thinking pressure regulator, filter and pump replacement.

    Someone else said it was the cat on his Jeep, which I replaced recently already. So if I remove the front o2 sensor like it said it would indicate whether the cat is to blame again. Because it would create an opening to bypass the cat. As of right now I plan to have the filter, pump, and fuel regulator replaced on next payday and day off.

    If it were the pcm I can't see spraying the throttle body and it restarting when it stalls and doesn't want to start. My tank will be nearly empty when payday gets here. I'm going to have a mechanic look at it before doing the replacement. Last mechanic said nothing was wrong. The fuel pressure reading the other day was within specs...but it wasn't acting up. I read the fuel pressure regulator can cause the backfire and stalling. I don't have any current active codes. If I don't get this fixed soon I will probably never own another Jeep product. I love the way it drives except for the stalling and backfiring. I almost got wiped out last night by a behicle when it stalled and I pulled into ditch by a curve. What do u think???

  10. #10
    Join Date
    Oct 2011
    Location
    S.E. Texas
    Posts
    29,250
    Chats
    1247

    Default Re: Problem with my 1993 XJ 4.0

    Quote Originally Posted by Floridajeepcherokee View Post
    Ok today driving to work it stalled or tried and didn't do much tonight but tried once or twice. I replaced horn and fuel pump relay so its not the relay because it still back fired and tried stalling, If it were the pcm I cant see throwing it in neutral and revving it slightly which seems to prevent the stall....as a pcm issue. As of now I'm thinking pressure regulator, filter and pump replacement.

    Someone else said it was the cat on his Jeep, which I replaced recently already. So if I remove the front o2 sensor like it said it would indicate whether the cat is to blame again. Because it would create an opening to bypass the cat. As of right now I plan to have the filter, pump, and fuel regulator replaced on next payday and day off.

    If it were the pcm I can't see spraying the throttle body and it restarting when it stalls and doesn't want to start. My tank will be nearly empty when payday gets here. I'm going to have a mechanic look at it before doing the replacement. Last mechanic said nothing was wrong. The fuel pressure reading the other day was within specs...but it wasn't acting up. I read the fuel pressure regulator can cause the backfire and stalling. I don't have any current active codes. If I don't get this fixed soon I will probably never own another Jeep product. I love the way it drives except for the stalling and backfiring. I almost got wiped out last night by a behicle when it stalled and I pulled into ditch by a curve. What do u think???
    I may not have a lot of info on this (sorry) but i will say my moms '93 zj had a LOT of problems with its fuel pump, probably replaced 5-6 times. Now, i can't say if there's any connection though. Hope this gets resolved soon for ya.

    Sent via messenger pigeon - i talk, he types.

  11. #11
    Join Date
    Jun 2013
    Location
    Florida
    Posts
    237
    Chats
    14

    Default Re: Problem with my 1993 XJ 4.0

    me too. It threw a code tonight but haven't coded it yet.

  12. #12
    Join Date
    Jul 2012
    Location
    Birmingham, AL
    Posts
    36
    Chats
    2

    Default Re: Problem with my 1993 XJ 4.0

    Quote Originally Posted by ArmyGuy45 View Post
    Crank Shaft Position Sensor.
    This

  13. #13
    Join Date
    Jun 2013
    Location
    Florida
    Posts
    237
    Chats
    14

    Default Re: Problem with my 1993 XJ 4.0

    That was changed . Fuel pressure indicated good and it actually acted up today at mechanic . Mechanic thinks its the pick up coil or cam shaft sensor. But it's the pick up sensor not sure if these are 1 part but he thinks its the pick up sensor.

Similar Threads

  1. 1993-1998 Jeep ZJ Cherokee Winch Bumper - 4WheelingPlus
    By RTPG in forum GC - Vendors FOR SALE
    Replies: 0
    Last Post: 09-10-2012, 12:44 AM
  2. Replies: 6
    Last Post: 09-27-2011, 04:29 AM
  3. Replies: 0
    Last Post: 11-19-2010, 02:14 AM
  4. 1993 XJ Country Edition
    By Melissa in forum For Sale
    Replies: 0
    Last Post: 05-24-2010, 11:20 PM
  5. 1993 2dr sport
    By finneys98xj in forum For Sale
    Replies: 11
    Last Post: 04-27-2010, 09:10 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •