Results 1 to 6 of 6
  1. #1
    Join Date
    Jun 2012
    Location
    qatar
    Posts
    3
    Chats
    0

    Default Power loss, valves ticking, feels heavy to run then stop with a boiling reserv tank..

    Hi, I have some problem with my 1997 XJ Sport 4.0 recently. The car is running normal when I constantly drive around 80km/h with a temperature needle remain in the middle of the indicator. But if I hit the gas and let it run a bit aggresive around 100-120km/h for 15-20 minutes the temperature will get up one more bar more than half of the indicator then the car start to loosing power. The car feels heavy/hard to run and with a ticking sound from the valves, it's feels like a manual gear vehicle climbing a hill and need to shift down (my car is automatic gear). If I keep the car running on that condition for about 15 minutes the coolant in reservoir tank will get boiled with a gurgling sound came from under the radiator cap as well.. Have check the radiator water, check the radiator cap, check the engine oil everythings was fine, no leakage and not less than standard. My car also equiped with extra fan and oil cooler as I'm staying in middle east.

    Can anyone advised me what happened and how to solve it? Thanks

  2. #2
    Join Date
    Nov 2011
    Location
    Cyprus
    Posts
    209
    Chats
    0

    Default Re: Power loss, valves ticking, feels heavy to run then stop with a boiling reserv ta

    If you're not losing coolant and the level inside the overflow reservoir isn't going down, it's just possible that your radiator cap isn't holding pressure and is allowing the coolant to boil. It's a simple cheap fix to replace it and see if it cures the problem.
    Also remove the overflow reservoir and rinse it out thoroughly. Sediments can build up at the bottom and prevent coolant being sucked back into the radiator when the engine's cooling down.
    Last edited by Cheromaniac; 08-25-2012 at 04:28 AM.

    1992 XJ - 4.6L Stroker - AX15 - Sold 13/12/2016
    202rwhp 258rwtq (248bhp 311lbft crank)
    Jeep Performance, Jeep Tech, Junker to Stroker

  3. #3
    nickxj94's Avatar
    nickxj94 is offline Level: Uber Jeep Cherokee Trailer Queen
    Join Date
    Apr 2012
    Location
    Arkansas
    Posts
    1,250
    Chats
    1

    Default

    Replace the radiator cap first, if it still does it replace the thermostat. Just did that on a buddies 96xj and solved the problem! I replaced both cap and tstat.
    --______......
    . /__| _ | _\ / / \,____.
    |/ \ \_ | _/_/ \|EIIIIIIEI
    '( o ))-=--) ( o ))--=--)).Just another GREEN XJ lifted on 33's

  4. #4
    Join Date
    Sep 2009
    Location
    Chico, CA
    Posts
    29,677
    Chats
    1838

    Default Re: Power loss, valves ticking, feels heavy to run then stop with a boiling reserv ta

    Seto, fill it up enough that the coolant level is in the fill neck where the cap goes. Start the engine and let it idle. If you continually get bubbles there, you have a bad head gasket. It sounds like when you are running it hard that the head and oil temps are getting too high, thinning the oil and you are either getting lifter noise or engine knocking from too high heat temps. The only cure for this is replacing the head gasket.
    230 hp 4.3L Chevy
    Built 4L60E with manual lockout
    Atlas 4 speed
    Griffin radiator
    On board air
    Warn 9.5ti on custom bumper
    7.5" RE front and bastard pack rear on custom long arms
    30 gal gas tank
    lockers
    And a bunch of other stuff

  5. #5
    Join Date
    Aug 2011
    Location
    NSW Australia
    Posts
    5,210
    Chats
    3129

    Default Re: Power loss, valves ticking, feels heavy to run then stop with a boiling reserv ta

    X 2 on rad cap and then thermostat.

    Rad cap needs to be the type that allows flow, both ways.

    Ensure you have enough coolant in the system ... as 4.3LXJ mentioned ... not just the overflow bottle ... and maybe check that the overflow tube isnt clogged.

    Head gasket is possible ... That overheating issue you had a while back - may have caused some problems ??
    I hate watching simplicity and reliability being ruined by bureaucracy and technology.

    Quote Originally Posted by MattybPDX
    If my jeep is going to be a grocery getter it's at least going to be a friggin awesome one.

  6. #6
    Join Date
    Jun 2012
    Location
    qatar
    Posts
    3
    Chats
    0

    Default Re: Power loss, valves ticking, feels heavy to run then stop with a boiling reserv ta

    Have opened the cap and let the engine run til hot, no bubbles.. Have checked the thermostat, it's working fine.. Will try to replace the cap tomorrow and if no luck then will replace the gasket and clean the water line.. Will keep you all updated..

Similar Threads

  1. Replies: 5
    Last Post: 08-01-2012, 03:26 PM
  2. Replies: 4
    Last Post: 06-26-2012, 01:10 PM
  3. TURN SIGNAL Loss
    By 88AMCOMANCHE in forum OEM/Factory
    Replies: 30
    Last Post: 05-13-2011, 08:08 PM
  4. 4x4 feels like its binding
    By xj89 in forum OEM/Factory
    Replies: 17
    Last Post: 12-30-2009, 05:23 PM
  5. Ticking, Overheating, and Milkshakes...
    By TimJ408 in forum OEM/Factory
    Replies: 6
    Last Post: 10-06-2009, 07:21 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •