PDA

View Full Version : Need help, cant find correct place to ask



88AMCOMANCHE
02-15-2011, 06:34 PM
sorry if this is in the wrong section. Trying to post in the help forums.cant find the "post" link for new posts.
My 88 Jeep has a problem,started about a year ago....click key on nuthing,back off,then on & nuthing do this a few times & it then fires right up. over time this problem has esculated to where it takes 20 clicks on/off to start the 4.0 Jeep. So......I replace the Ignition Key switch on the column........which made NO difference........then i replace the starter ignition switch further down the column behind the dash......Made No difference. Now what? I used a screw driver to jump across teh cellonoid screws & it DID engage the starter . so Im lost as to what I need to replace. Would a Cellonoid cause this problem maybe? dying to start My jeep up again & let it run for a while. Hope Someone can answer this. Anyone. Drawing straws here. :stars:

bigjim350
02-15-2011, 07:00 PM
Sounds like a bad Neutral Safety Switch. Or guess it could be a bad solenoid on the starter.

bluedragon436
02-15-2011, 07:02 PM
^^ +1!!

4.3LXJ
02-15-2011, 07:30 PM
You can always pull the starter and have it checked for nothing. But I think the NSS clean up job is the solution. Melissa, one of our female members has a nice write up on cleaning hers.

XJ4IV
02-15-2011, 07:36 PM
I would pay you 50 bucks if it ISNT the neutral safety switch, what you CAN do is run a momentary switch or button to the starter this bypasses the NSS then all you do is put your key in turn to the position it returns to after starting it... then just push the button till it starts... Ive done that and never looked back

DETOURS
02-15-2011, 07:48 PM
I'll bet 2 bucks it's your starter solenoid the hole time, $45 should get the starter totally rebuilt......... remove & check the local yellow pages
or
Buy a rebuilt from NAPA/Rockauto.com, etc for almost double.....

Link: http://www.rockauto.com/catalog/x,carcode,1181584,parttype,4152

4.3LXJ
02-15-2011, 07:51 PM
I would pay you 50 bucks if it ISNT the neutral safety switch, what you CAN do is run a momentary switch or button to the starter this bypasses the NSS then all you do is put your key in turn to the position it returns to after starting it... then just push the button till it starts... Ive done that and never looked back


I'll bet 2 bucks it's your starter solenoid the hole time, $45 should get the starter totally rebuilt......... remove & check the local yellow pages
or
Buy a rebuilt from NAPA/Rockauto.com, etc for almost double.....

Link: http://www.rockauto.com/catalog/x,carcode,1181584,parttype,4152

Before I spent any money or did anything, I would hook up a remote starter switch to the starter relay and check that. Then I wouldn't have to lay down any bets.

XJ4IV
02-15-2011, 08:58 PM
Before I spent any money or did anything, I would hook up a remote starter switch to the starter relay and check that. Then I wouldn't have to lay down any bets.

I bet MONEY that 4.3 has the BEST answer! but the remote starter... is the same thing as the momentary switch

easttxhunter
02-15-2011, 09:05 PM
I'm thinking that if it was the neutral safety switch it wouldn't do anything. But you can try starting it in neutral rather than drive to test it.

JENSSEN
02-15-2011, 09:28 PM
A rotten wire off the block connector that bolts to the fuse panel can do this too

88AMCOMANCHE
02-15-2011, 10:00 PM
a Momentay switch? I found a thing that is mounted about 4 inches from ther battery, mounted on the Pass.fender somehow. It has like 4-5 screw studws with terminal ends & wires go to. From one of tose stud screws,theres a greenish wire that leads down to the starter sillonoid & attaches to the small screw on there. sorry if this is confusing.

88AMCOMANCHE
02-15-2011, 10:01 PM
when it does run....it can start in any gear. so Im assuming there is no NSS or else its unhooked maybe.

88AMCOMANCHE
02-15-2011, 10:02 PM
the Fuse panel? Inside the truck under the dash? the MAIN fuseblock?

easttxhunter
02-15-2011, 10:29 PM
Manual?

4.3LXJ
02-15-2011, 11:09 PM
a Momentay switch? I found a thing that is mounted about 4 inches from ther battery, mounted on the Pass.fender somehow. It has like 4-5 screw studws with terminal ends & wires go to. From one of tose stud screws,theres a greenish wire that leads down to the starter sillonoid & attaches to the small screw on there. sorry if this is confusing.

That is your starter relay. If you hook up a remote switch, then you would use that relay. The green goes to the starter solenoid, black or black stripe is ground and the other is from the ign switch. The ground goes to the NSS. So if you hook up a switch or if you are gutsy, use a screw driver and arc the large post which is hot off the battery to the post with the yellow (I think) and it should operate the starter if it is in park or neutral. If not, you can ground the post with the black wire to the body and try again. If it works, then it is the NSS. If not, pull the starter and have it checked.

BlueXJ
02-15-2011, 11:15 PM
Everyone has stated the common problems but I had the same symptoms with my MJ and I finally traced it to a bad connector inside the ignition switch. That switch is located at the base of the steering column. I think it was less than
$20 to replace.

http://shop.advanceautoparts.com/webapp/wcs/stores/servlet/product_Ignition-Starter-Switch-BWD_5971209-P_410_R|GRPSESWAM

88AMCOMANCHE
02-16-2011, 10:22 AM
Thanx Blue. Ive replaced both the Key ignition switch And the Ignition switch thats down the column a little ways just behind the dash but it hasnt corrected the problem yet. I will keep trying to track it down. Im starting to lean towards either the relay sellonoid that mounts up near the battery trey, or the starter sellonoid thats on the starter.

88AMCOMANCHE
02-17-2011, 01:51 PM
UPDATE : ........I have removed the NEW ignition swicth from under the dash ontop of the column, I wanted to Manually see if I could start the truck by putting a small tip screw driver in the slider hole (bypassing ignition key) and wouldnt ya know.......as soon as I slid the glider piece....the truck fired right up!
So...........now i know its the Ignition swicth and something in how its hooked up (theres 4 positions the slider can be in) ......Long Story long ........I NEED HELP figuring out HOW to get the Actuator rod into the little slider on the ignition starter switch. My question is: Does the rod where it makes a 90 degree turn upward...........does that go into the SIDE of the switch? or does it go into the BOTTOM of the switch??? ive spent 2 hours attempting to put this new switch back in. HELP, anyone? Actuator rode goes in bottom? or side? will check back later.

4.3LXJ
02-17-2011, 02:02 PM
It goes into the bottom of the switch. It gets sandwiched between the column and the underside of the switch. You will have to unbolt the switch to get it in properly. Just a thought, is your key switch functioning properly?

88AMCOMANCHE
02-17-2011, 05:47 PM
Key funtions correctly. Its only about 8 months old. Underneath the switch,you can see the slider mechanism and that peice has a sorta small hole,but its nowhere near big enough to get the actuator rod up into., Yet it looks as if it should go into the plastic slider piece,somewhere.

4.3LXJ
02-17-2011, 05:59 PM
Yes it should

88AMCOMANCHE
02-17-2011, 06:57 PM
http://img137.imageshack.us/img137/8862/1003430.jpg (http://img137.imageshack.us/i/1003430.jpg/)

Uploaded with ImageShack.us (http://imageshack.us)



Trying to upload a pic or two of the swicth & the acuator rod

88AMCOMANCHE
02-17-2011, 07:09 PM
The slot in the bottom of the switch has a few small holes. Yet neither are large enough for the actuator rod to fit up into......Plus the switch holes have to be in the "accesory" position (extended far end of the slide) ....This is insane why it wont simply sit down onto the rod like one would expect it to.
Ive even went back to advance & got the other model swicth for the non-tilt wheel version, which is simply the same unit,only the mount bracket is opposite of this one.
Should the rod be super tight going up into the hole of the switch? If the rod goes in the big open area underneath the swictch (not in the plastic hole) Then it would start the vehicle probably,yet wouldnt have anything to pull back on to turn the vehicle Off. Im SO stumped!! ...The ORIGINAL switch does Not have an Opening at the bottom at all,which really confuses me even more. This has me stressing. hope someone can solve this damn puzzle cuz i cant. heres another pic of the underside of the new switch (actuator rod sorta visible too)
(http://img17.imageshack.us/i/1003440n.jpg/)

Uploaded with ImageShack.us (http://imageshack.us)

88AMCOMANCHE
02-17-2011, 07:10 PM
http://img17.imageshack.us/img17/3217/1003440n.jpg (http://img17.imageshack.us/i/1003440n.jpg/)

Uploaded with ImageShack.us (http://imageshack.us)

88AMCOMANCHE
02-17-2011, 10:30 PM
P R O B L E M S O L V E D !! finally. would like to thank every1 for the info & pointers Cold beer goes out to Punisher for letting me know I when an Ignition swiitch ...is Upside down lol Thanx

Punisher
02-17-2011, 10:32 PM
P R O B L E M S O L V E D !! finally. would like to thank every1 for the info & pointers Cold beer goes out to Punisher for letting me know I when an Ignition swiitch ...is Upside down lol Thanx

Your welcome..... :thumbsup:

4.3LXJ
02-17-2011, 10:36 PM
It doesn't fit tight. It just slips in. One option you might want to consider. Is there something wrong on the rod? In my case, if it didn't reach far enough, I would just extend the rod. Tomorrow I will try to glance at mine if I can without taking stuff apart.

88AMCOMANCHE
02-18-2011, 10:59 PM
Its ok, the switch is already installed FINALLY. now it fires right up, 1st try.

88AMCOMANCHE
04-06-2011, 10:07 PM
<a target='_blank' title='ImageShack - Image And Video Hosting' href='http://img840.imageshack.us/i/1003466.jpg/'><img src='http://img840.imageshack.us/img840/5558/1003466.jpg' border='0'/></a>

Still needing a Headliner or a Headliner Board so I can make my own. Ideas? <a target='_blank' title='ImageShack - Image And Video Hosting' href='http://img148.imageshack.us/i/1003464d.jpg/'><img src='http://img148.imageshack.us/img148/223/1003464d.jpg' border='0'/></a>


Interior finally put back in...slight dye to the carpet,decided to reuse it. sort of a Blue/gray tiedye kinda <a target='_blank' title='ImageShack - Image And Video Hosting' href='http://img28.imageshack.us/i/1003460n.jpg/'><img src='http://img28.imageshack.us/img28/5052/1003460n.jpg' border='0'/></a>

88AMCOMANCHE
04-06-2011, 10:09 PM
<a target='_blank' title='ImageShack - Image And Video Hosting' href='http://img28.imageshack.us/i/1003460n.jpg/'><img src='http://img28.imageshack.us/img28/5052/1003460n.jpg' border='0'/></a>

88AMCOMANCHE
04-06-2011, 10:10 PM
http://img28.imageshack.us/img28/5052/1003460n.jpg (http://img28.imageshack.us/i/1003460n.jpg/)

Uploaded with ImageShack.us (http://imageshack.us)

88AMCOMANCHE
04-06-2011, 10:16 PM
FINALLY got my interior back in. The dirt REALLY shows up in teh picture. Ive never seen all that in person,till looking at this picture.Maybe the lighting. I mounted my gauge set in the front section of the console.Sits there steady & almost made for it,but still need to fasten it to the console with 2 small screws.
http://img856.imageshack.us/img856/2503/1003461.jpg (http://img856.imageshack.us/i/1003461.jpg/)

88AMCOMANCHE
04-06-2011, 10:20 PM
MY Headliner-less roof. ....Still have to find a headliner, OR a headliner Board from someowhere. Originally i wanted to get a sheet of ABS 1/8" plastic & mount it using tiny sheetmetal screws, but i cant find a sheet big enough,next option is Luan board from H.D .....any suggestions under 100$ ?
http://img696.imageshack.us/img696/6755/1003464.jpg (http://img696.imageshack.us/i/1003464.jpg/)

88AMCOMANCHE
04-06-2011, 10:23 PM
PS-Im IGNORING the sunroof when i install whatever headliner i go with ......just using a large sheet of roll fiberglass for insulation,thinner along sunroof frame to accomodate space. I sealed off the headliner from the top so its Non funtional.